Preview Mesh Display Issue

3 replies [Last post]
McBradd's picture
Posts: 9


I'm working on a model that I imported from 3ds Max with a multi-sub object containing 4 separate maps. Now I'm working on the texture in UDK and Photoshop.

When I view the model in the static mesh browser, it looks correct.
However, when I view the model in the Material Editor, the texture I am working on always ends up in the first material slot on the mesh.

How do I preview the model correctly while editing the material?

JackyBoy's picture
Posts: 344

I havent got the Next Gen Materials DVD on this computer's hard drive at the mo, but I am pretty certain he tells you how to do it in there. You need to plug something into the UV channel part of the Diffuse texture, otherwise it will just keep putting it in channel 1. If you don't have the DVD get it Sticking out tongue if you do, it's the part where he goes over making modular rubble


Riki's picture
Posts: 1257

 Thanks JackBoy! Im trying to think off the top of my head and I think there is a limitation with the material editor, that when you select a previewmesh it will fill that material over the entire surface. The only way I know how to get realtime feedback like you are after is if you were adjusting Material Instances and not Materials. Thats probably not what you are after. What you probably have to do is just adjust things and click the green checkbox to see it update in the scene. 


McBradd's picture
Posts: 9

Thanks for the quick responses guys. I tried plugging a UV coordinate node, but the problem is that which ever texture I am editing shows up in the 0 slot, in addition to its correct UV location. This is more of an annoyance than anything serious. On this particular model, '0' is the Cab. Consequently, when I'm working on the Cab texture itself, everything looks fine.

Also, congrats on being recognized in the Autodesk Masters Riki!